Mazda MX-30 Forum banner
1 - 20 of 20 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
Hi,

My latest problem is that MyMazda app does not connect to my Mx-30. I can't check from the app is my car charging, range, is doors locked or anything else. It's displayed last thursday's information when it stop working. I tried to delete app and upload it again and something like that but I can't solve this issue with myself. So is there someone who had same issue and can you fix it yourself, or should I call to local Mazda dealer and give it to them check it out.
 

·
Registered
Joined
·
718 Posts
You could check this before dealership

A. The car's esim is active


B. Can you display any status information or messages?

C. Have you driven any distance to see if it reconnects?

D. Can you check using another device such as tablet?


Alan
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #3 ·
Hi,

Thank's for these, I was earlier today thinking where can I found that esim connections but my old eyes didn't found it😂😵‍💫
But to the point,
A, esim to be seem is active.
B, if you mean status information and messages in the app(sorry if I didn't understand correctly) I can see only from the time when app works normally. But if I try for example lock doors then it send message; door locking failed.
C, yes we have driven every day atleast once so that should not be the problem.
And D, now I tried to download app to another phone and it show that same old information from the time when app works normally.

What if I delete my car from the app and cancel connected services. I haven't tried it yet, but if I try will it cause any additional problems to me.
 

·
Registered
Joined
·
718 Posts
Try this first

Press and hold down the volume knob, back button, and NAV button for about 10 seconds. This will reset your MAZDA CONNECT™ system.

I suspect that the app to server communications are OK given you get a fail message. Unless the server database has corrupted the car data then it points to the car to server communications. I don't think deleting your registration data will resolve the issue as you are only deleting the car side of the registration, which appears to be OK. If the above fails to resolve the problem then one last thing, if you are confident, is to disconnect and reconnect the 12v battery to reset comms. Having done it myself it doesn't affect the car settings.

Alan
 

·
Registered
Joined
·
16 Posts
Hi,

My latest problem is that MyMazda app does not connect to my Mx-30. I can't check from the app is my car charging, range, is doors locked or anything else. It's displayed last thursday's information when it stop working. I tried to delete app and upload it again and something like that but I can't solve this issue with myself. So is there someone who had same issue and can you fix it yourself, or should I call to local Mazda dealer and give it to them check it out.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #8 ·
Yes it was registered and I cancel it and I registered it again but still doesn't work as you previously guessed. I also try few times that mazda connect resetting but that button combination does nothing.
So I called to Mazda dealer and I take it to there in couple of weeks. They get to look and fix it, because the car is still under warranty.
Thanks anyway, and I let you guys know what was wrong with it when it's fixed.
 

·
Registered
Mazda
Joined
·
43 Posts
Yes it was registered and I cancel it and I registered it again but still doesn't work as you previously guessed. I also try few times that mazda connect resetting but that button combination does nothing.
So I called to Mazda dealer and I take it to there in couple of weeks. They get to look and fix it, because the car is still under warranty.
Thanks anyway, and I let you guys know what was wrong with it when it's fixed.
IMO, there is part of your problem because you registered and then cancelled it, you might have conflicts within APP directory...
Go to App Setting, then find MyMazda App, storage and clear (delete) storage files and delete cache,
reboot phone and login/register with details and VIN, etc.
I have not done this but is a method to reset App.
 

·
Registered
Mazda
Joined
·
43 Posts
Who's instructions, if you are referring to me I am talking App on phone (android). Connect reset should be in Settings.
 

·
Registered
Joined
·
718 Posts
Ash8 my previous cx5 Mazda connect (car not app) could be soft reset using a combination as described above in the thread. So I am talking vehicle not app end. See below for old instructions. Is there a new combo for the MX30 that you are aware of? I suspect the "cannot connect app to car" problem is a Comms module error in the car and wondered if a soft reset would work or if it requires odb connection to reset the error using proprietary software

Alan

Press and hold down the volume knob, back button, and NAV button for about 10 seconds. This will reset your MAZDA CONNECT™ system.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #13 ·
Hi,

It won't work still, even if I do all of those app setting resetting.
And that mazda connect resetting button combination won't do anything.
But now app show me sometimes error code 400C04.
Somewhere in the internet I found cases where the same happened and in those cases it apparently means software update to be done in mazda service.
 

·
Registered
Mazda
Joined
·
43 Posts
Yes I am still looking have some sort of relevant material, but like I said before most of this has to be done @ Dealer (Module Resets and TCU (telecom control unit) updates) level with MDARS, VCM II, and with full Dealer access.
Mazda 3, CX-30, CX-5 and CX-9 have all had TCU Firmware updates but I cant see anything for MX-30...yet.

But IMO your issue may be related to first registering and cancelling APP.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #15 ·
App stop working suddenly and has not working after that. After app stop working I wait couple of days if It started working and only after that I delete app and cancelled mazda connect service and I removed car from the app and start everything from the beginning. Second time when I fed the vin etc. to the app and it show right car and model but none of the remote functions work.
I believe that app deleting and what I done is not the problem, because as I earlier say that the app stops working suddenly.
But Mazda service can find it out and hopefully it is just software update.
 

·
Registered
Mazda
Joined
·
43 Posts
I am not seeing any issues in Dealer portal my contact has, not to say there are none, but really without connecting car to MDARS we are just chasing tails...
Here are just a few tasks that require MDARS at Dealer level....

TELEMATICS COMMUNICATION UNIT INITIAL SETTINGS

1.Connect the M-MDS (MDARS) to the DLC-2.

2.Switch the main power ON (READY off).

3.Activate the M-MDS and perform the following procedure.

(1)Press [Start] to start the vehicle identification.
(2)Press the [Toolbox] tab.
(3)Press the [Work Support] icon.
(4)Press [Mazda Connect].
(5)Press [Run] for [Activating TCU].
4.Perform [Activating TCU] according to the directions on the M-MDS screen.



WINDSHIELD WIPER ARM AND BLADE INITIAL SETTINGS

1.Connect the M-MDS (MDARS) to the DLC-2.

2.Switch the main power ON (READY off).

3.Activate the M-MDS and perform the following procedure.

(1)Press [Start] to start the vehicle identification.
(2)Press the [Toolbox] tab.
(3)Press the [Work Support] icon.
(4)Press [WIPER/WASHER SYSTEM].

Note
• When [Run] for [Calibrating Front Wiper position] is pressed,
the windshield wipers operate and the driver’s windshield wiper blade moves close to the A pillar.

(5)Press [Run] for [Calibrating Front Wiper position].
(6)Confirm the Calibrating Front Wiper position procedure from Step (7) to Step 11, and press [Next].
(7)Verify that the main power is switched ON (READY off or on) and press [Next].

Note
• Perform the work from Step (8) to Step 7 within 10 min.
(8)When [Carry out the position learning of the wiper according to the service procedures recommended in the workshop manual.]
is displayed, move to the driver’s windshield wiper arm and blade calibration procedure.

4.Lift the driver's windshield wiper blade by hand and lower it gently.

5.Verify that the driver's windshield wiper blade is at the position shown in the figure.

• If the driver's windshield wiper blade is not at the position shown in the figure, move the driver's windshield wiper arm by hand to adjust it and then return to Step 4.
6.Switch the light switch to OFF. (With headlight cleaner)

Note
• When [Calibrating Front Wiper position] is performed, the windshield wipers return to their initial positions.

7.Pull the windshield wiper switch 2 times and perform [Calibrating Front Wiper position].

8.Return to the M-MDS operation and press [Next].

9.Switch the main power OFF and press [Next].

10.Switch the main power ON (READY off) and press [Next].

11.Press [Next] to complete [Calibrating Front Wiper position].

12.Inspect for DTCs. (See DTC INSPECTION.)

• If a DTC is detected, repair the malfunctioning location according to the applicable DTC troubleshooting.
(See DTC TABLE [BODY CONTROL MODULE (BCM.)

VEHICLE STATUS MONITOR SETTINGS

Note
• The body control module (BCM) stores the vehicle status monitor setting values.
• Before replacing the BCM, explain to the customer that the vehicle status monitor will be reset to the initial set values.
1.Switch the main power ON (READY off or on).

2.Select [Information] on the Home screen to display the vehicle status monitor.

3.Select [Vehicle Status Monitor]

4.Select [Vehicle Maintenance Settings].

5.Select the following items and set the vehicle status monitor.

Indication on center display

Setting contents

Next Service Date *1
Automatic/Manual
Set Next Service Date *2
Year: 2020 - 2050
Month: 1 - 12
Day: 1 - 31
Set Next Service Distance *2
500 - 30000 km / 250 - 18750 mi
Reset Service Interval
Reset
*1:The initial set value is [Automatic].
*2:If [Next Service Date] is set to [Manual], the setting can be changed.


VEHICLE CONTROL MODULE (VCM) INITIAL SETTING

1.Connect the M-MDS (MDARS) to the DLC-2.

2.Switch the main power ON (READY off).

3.Activate the M-MDS and perform the following procedure.

(1)Press [Start] to start the vehicle identification.
(2)Press the [Toolbox] tab.
(3)Press the [Work Support] icon.
(4)Press [BRAKES].
(5)Press [Run] for [Calibrating Yaw Rate for VCM].
(6)Confirm the Calibrating Yaw Rate for VCM procedure from Step (7) to Step (10) and press [Next].
(7)Verify that the main power is switched ON (READY off) and press [Next].
(8)Press [Next] to perform [Calibrating Yaw Rate for VCM].
(9)When the M-MDS processing is completed, press [Next].
(10)Press [Next] to complete [Calibrating Yaw Rate for VCM].
 

·
Registered
Mazda
Joined
·
43 Posts
App stop working suddenly and has not working after that. After app stop working I wait couple of days if It started working and only after that I delete app and cancelled mazda connect service and I removed car from the app and start everything from the beginning. Second time when I fed the vin etc. to the app and it show right car and model but none of the remote functions work.
I believe that app deleting and what I done is not the problem, because as I earlier say that the app stops working suddenly.
But Mazda service can find it out and hopefully it is just software update.
What phone OS do you use, is it Android or i-Phone, if you are Android and have not done so it maybe worth giving below a try.

For Android users (this is not new news) but the Android Auto App (by Google is being withdrawn).
If you use a later Android OS you are asked to Uninstall the AA App as this is now incorporated in 'Google' system apps.
Everything should connect and work as normal with correct USB cable (this is what i-phone already has).
There are some conflict issues with MyMazda APP and now obsolete Android Auto App according to Mazda to Dealers.
 

·
Registered
Joined
·
58 Posts
Do you use some antivirus or anti malware software on your phone?
If so, remove it.
Also delete the mazda connect app and the link (account) with your car.
reinstall the mazda connect app and go to the proces of linking the app to your car.
This worked for me.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #19 ·
No i don't have any antivirus or anything like that, just basic android phone.
And I have also done those couple times but it still not working.
Bluetooth connection and android auto works normally in the car but app won't in the car or away from the car.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #20 ·
Suddenly yesterday app reported that doors are unlocked. After that all remote commands via the app works normally.
Time for maintenance would be wednesday, but I still take it there so they can check is all updates are ok.
 
1 - 20 of 20 Posts
Top